What’s Vulnerable › Vulnerabilities
CVE-2026-104417: Ghost 1.20.0 before 6.64.0 Path Traversal via Locale Setting
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-02 · updated 2026-10-02
- Weakness: CWE-22
Description
Ghost from 1.20.0 before 6.64.0 contains a path traversal vulnerability in theme translation file loading that allows authenticated administrators to read JSON files outside the active theme directory. Attackers can manipulate the locale setting to load JSON files elsewhere on the server, exposing server configuration secrets.
Affected products
- TryGhost Ghost: from 1.20.0 before 6.64.0 — fixed in 6.64.0
How to fix
Upgrade to a fixed version: TryGhost Ghost 6.64.0. Check the vendor advisory for mitigations.
References
- https://github.com/TryGhost/Ghost/security/advisories/GHSA-m382-6jw4-fmp6
- https://www.vulncheck.com/advisories/ghost-1.20.0-before-6.64.0-path-traversal-via-locale-setting
Get alerted when CVE-2026-104417 or the next vulnerability affects your stack