What’s Vulnerable › Vulnerabilities
CVE-2026-104431: Zebra before 6.0.0 Denial of Service via Synchronous Script FFI Verification
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-02 · updated 2026-10-02
- Weakness: CWE-405
Description
Zebra before 6.0.0 contains a denial of service vulnerability that allows unauthenticated peers to stall Tokio workers by submitting mempool transactions requiring expensive synchronous script verification. Attackers can send non-standard high-sigop P2SH transactions that reach CachedFfiTransaction::is_valid() before standardness checks, saturating the verifier buffer and rendering the node unresponsive.
Affected products
- ZcashFoundation zebra: before 6.0.0 — fixed in 6.0.0
How to fix
Upgrade to a fixed version: ZcashFoundation zebra 6.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/ZcashFoundation/zebra/security/advisories/GHSA-84j3-rw4c-gqmj
- https://www.vulncheck.com/advisories/zebra-before-6.0.0-denial-of-service-via-synchronous-script-ffi-verification
Get alerted when CVE-2026-104431 or the next vulnerability affects your stack