What’s Vulnerable › Vulnerabilities
CVE-2026-104466: YesWiki before 4.6.7 Stored XSS via Wakka Markdown Image src Attribute
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-02 · updated 2026-10-02
- Weakness: CWE-79
Description
YesWiki before 4.6.7 contains a stored cross-site scripting vulnerability in formatters/wakka.php that allows users who can edit pages or post comments to inject event handlers by placing quotes in markdown image URLs. Attackers can store a crafted markdown image whose src breaks out of the attribute to add an onerror handler, executing JavaScript in viewers' browsers, including administrators.
Affected products
- yeswiki: before 4.6.7 — fixed in 4.6.7
How to fix
Upgrade to a fixed version: yeswiki 4.6.7. Check the vendor advisory for mitigations.
References
- https://github.com/YesWiki/yeswiki/security/advisories/GHSA-7pv9-pwm8-cwwr
- https://www.vulncheck.com/advisories/yeswiki-before-4.6.7-stored-xss-via-wakka-markdown-image-src-attribute
- https://github.com/YesWiki/yeswiki/security/advisories/GHSA-7pv9-pwm8-cwwr
Get alerted when CVE-2026-104466 or the next vulnerability affects your stack