What’s Vulnerable › Vulnerabilities
CVE-2026-104474: OpenLiteSpeed before 1.9.3 Local Privilege Escalation via lsup.sh Auto-Update
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-03 · updated 2026-10-06
- Weakness: CWE-367
Description
OpenLiteSpeed before 1.9.3 contains a local privilege escalation vulnerability in admin/misc/lsup.sh that runs unverified update packages from a nobody-writable directory as root. Attackers controlling the nobody web process can replace the package in /usr/local/lsws/autoupdate/ before extraction, so its install.sh runs as root on the next update.
Affected products
- LiteSpeed Technologies OpenLiteSpeed: before 1.9.3 — fixed in 1.9.3
How to fix
Upgrade to a fixed version: LiteSpeed Technologies OpenLiteSpeed 1.9.3. Check the vendor advisory for mitigations.
References
- https://github.com/litespeedtech/openlitespeed/blob/v1.9.2/dist/admin/misc/lsup.sh#L538
- https://github.com/litespeedtech/openlitespeed/commit/468523ce84388cea9ba6633c26517bc05b3e2bc1
- https://openlitespeed.org/release-log/version-1-9-x/
- https://www.vulncheck.com/advisories/openlitespeed-before-1.9.3-local-privilege-escalation-via-lsup-sh-auto-update
Get alerted when CVE-2026-104474 or the next vulnerability affects your stack