What’s Vulnerable › Vulnerabilities
CVE-2026-104652: Envira Gallery < 1.16.1 - Author+ Stored XSS via Gallery Image ID
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-07 · updated 2026-10-07
- Weakness: CWE-79
Description
The Envira Gallery WordPress plugin before 1.16.1 does not sanitise and escape a gallery item identifier before outputting it in an image tag attribute, allowing users with the Author role and above to inject arbitrary web scripts that execute when any visitor, including an administrator, views a page embedding the gallery.
Affected products
- Envira Gallery: before 1.16.1 — fixed in 1.16.1
How to fix
Upgrade to a fixed version: Envira Gallery 1.16.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-104652 or the next vulnerability affects your stack