What’s Vulnerable › Vulnerabilities
CVE-2026-104653: Envira Gallery < 1.16.1 - Author+ Stored XSS via Gallery Crop Dimensions
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-07 · updated 2026-10-07
- Weakness: CWE-79
Description
The Envira Gallery WordPress plugin before 1.16.1 does not sanitise or escape user-supplied gallery display configuration values before storing them and outputting them in an image tag attribute, allowing users with the Author role and above to inject arbitrary web scripts that execute when any visitor, including an administrator, views a page containing the affected gallery.
Affected products
- Envira Gallery: before 1.16.1 — fixed in 1.16.1
How to fix
Upgrade to a fixed version: Envira Gallery 1.16.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-104653 or the next vulnerability affects your stack