What’s Vulnerable › Vulnerabilities
CVE-2026-104658: Reliance on Untrusted Inputs in a Security Decision in hMailServer
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-08 · updated 2026-10-08
- Weakness: CWE-807
Description
The Linux live-update apply helper (hmailserver-update) of Progressive Robot hMailServer 6.3.4 and 6.3.5 runs as root on a request file written by the unprivileged hmailserver service account, and took from that request the program used to verify an AppImage update's signature and the systemd unit to stop before reading the service account's files. An attacker who already runs code as the hmailserver service account, for example through another flaw in the mail server, can therefore have arbitrary code executed as root, on any Linux installation where the live update's path unit is active - the default for the project's .deb and .rpm packages - and on AppImage installations run under that unit.
Affected products
- Progressive Robot Ltd hMailServer: from 6.3.4 before 6.3.6 — fixed in 6.3.6
How to fix
Upgrade to a fixed version: Progressive Robot Ltd hMailServer 6.3.6. Check the vendor advisory for mitigations.
References
- https://gitlab.com/hmailserver/hmailserver/-/releases/v6.3.6
- https://gitlab.com/hmailserver/hmailserver/-/work_items/58
Get alerted when CVE-2026-104658 or the next vulnerability affects your stack