What’s Vulnerable › Vulnerabilities
CVE-2026-104661: Incorrect Privilege Assignment in GitLab
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-13 · updated 2026-10-14
- Weakness: CWE-266
Description
GitLab has remediated an issue in GitLab EE affecting all versions from 17.0 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an authenticated user holding a custom role with compliance framework administration permissions to configure and execute a specially crafted compliance pipeline across group projects due to improper privilege assignment.
Affected products
- GitLab: from 17.0.0 before 19.2.8; from 19.3.0 before 19.3.5; from 19.4.0 before 19.4.2 — fixed in 19.2.8, 19.3.5, 19.4.2
How to fix
Upgrade to a fixed version: GitLab 19.2.8, 19.3.5, 19.4.2. Check the vendor advisory for mitigations.
References
- https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-4-2-released/
- https://gitlab.com/gitlab-org/gitlab/-/work_items/621386
Get alerted when CVE-2026-104661 or the next vulnerability affects your stack