What’s Vulnerable › Vulnerabilities
CVE-2026-104677: WP Coder 4.0 - 4.5.1 - Editor+ RCE via Global PHP
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-07 · updated 2026-10-07
- Weakness: CWE-94
Description
The WP Coder WordPress plugin before 4.5.2 does not restrict access to its PHP code-execution feature to administrators, gating it on a content capability that the Editor role holds by default, which allows Editor-level users to save and execute arbitrary PHP code on the server and fully compromise the site.
Affected products
- WP Coder: from 4.0 before 4.5.2 — fixed in 4.5.2
How to fix
Upgrade to a fixed version: WP Coder 4.5.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-104677 or the next vulnerability affects your stack