What’s Vulnerable › Vulnerabilities
CVE-2026-104682: Envira Gallery < 1.16.2 - Contributor Missing Authorization via Convert Gallery REST Route
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-11 · updated 2026-10-13
- Weakness: CWE-862
Description
The Envira Gallery WordPress plugin before 1.16.2 does not correctly check authorization on its gallery-conversion feature, verifying that the requester can edit an arbitrary post they name rather than that they are allowed to create the Envira Gallery WordPress plugin before 1.16.2's own gallery content, allowing users with contributor-level access to create and publish gallery posts that the Envira Gallery WordPress plugin before 1.16.2's settings otherwise withhold from them.
Affected products
- Envira Gallery: before 1.16.2 — fixed in 1.16.2
How to fix
Upgrade to a fixed version: Envira Gallery 1.16.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-104682 or the next vulnerability affects your stack