What’s Vulnerable › Vulnerabilities
CVE-2026-104713: Apache Struts: Unbounded request body read in the REST plugin
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-05 · updated 2026-10-08
- Weakness: CWE-770
Description
Allocation of resources without limits or throttling vulnerability in the Apache Struts REST plugin. A request body is read into memory without any bound on how much will be accepted, so a single request can cause the server to allocate memory in proportion to its size, exhausting the Java heap and denying service to other users. No additional setting has to be enabled. Applications that do not use the REST plugin are not affected. This issue affects Apache Struts: from 2.1.8 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.11.0, from 7.0.0 through 7.3.0. Users are recommended to upgrade to version 6.12.0 or 7.4.0, which fixes the issue.
Affected products
- Apache Struts: from 2.1.8 through 2.3.37; from 2.5.0 through 2.5.33; from 6.0.0 before 6.12.0; from 7.0.0 before 7.4.0 — fixed in 6.12.0, 7.4.0
How to fix
Upgrade to a fixed version: Apache Struts 6.12.0, 7.4.0. Check the vendor advisory for mitigations.
References
- https://cwiki.apache.org/confluence/display/WW/S2-077
- http://www.openwall.com/lists/oss-security/2026/10/05/12
Get alerted when CVE-2026-104713 or the next vulnerability affects your stack