What’s Vulnerable › Vulnerabilities
CVE-2026-104893: Plane: Improper validation allows arbitrary modification of API token rate limits
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-05 · updated 2026-10-06
- Weakness: CWE-770
Description
Plane is an open-source project management tool. Prior to 1.4.0, GET /api/users/api-tokens/ allows an authenticated user to retrieve API-token records, while PATCH /api/users/api-tokens/{token_id}/ allows the user to modify the token's allowed_rate_limit field without server-side validation or a maximum value. A user can raise the limit arbitrarily and bypass intended API rate-limiting controls, enabling high-volume automated requests, backend resource abuse, and possible resource exhaustion. This issue is fixed in 1.4.0.
Affected products
- makeplane plane: before 1.4.0
References
- https://github.com/makeplane/plane/commit/edf247541301e482f2688c63481464b671ec579d
- https://github.com/makeplane/plane/pull/9148
- https://github.com/makeplane/plane/releases/tag/v1.4.0
- https://github.com/makeplane/plane/security/advisories/GHSA-xfgr-2x3f-g2cf
Get alerted when CVE-2026-104893 or the next vulnerability affects your stack