What’s Vulnerable › Vulnerabilities
CVE-2026-104905: FacturaScripts < 2026.7 PHP Object Injection via WidgetSelect
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-05 · updated 2026-10-06
- Weakness: CWE-502
Description
FacturaScripts before version 2026.7 contains a PHP object injection vulnerability in WidgetSelect::processFormData() that allows authenticated attackers to trigger unserialize() on raw POST data without an allowed_classes filter for multiple-select fields. Attackers can submit a serialized XLSXWriter object as the field value to invoke its __destruct() method, deleting arbitrary attacker-specified files such as config.php or backup data, resulting in denial of service and potential application reinstall hijack.
Affected products
- NeoRazorX facturascripts: from 2025.7 before 2026.7 — fixed in 2026.7
How to fix
Upgrade to a fixed version: NeoRazorX facturascripts 2026.7. Check the vendor advisory for mitigations.
References
- https://github.com/NeoRazorX/facturascripts/releases/tag/v2026.7
- https://github.com/NeoRazorX/facturascripts/security/advisories/GHSA-p89j-gj6f-fh6g
- https://www.vulncheck.com/advisories/facturascripts-php-object-injection-via-widgetselect
- https://github.com/NeoRazorX/facturascripts/security/advisories/GHSA-p89j-gj6f-fh6g
Get alerted when CVE-2026-104905 or the next vulnerability affects your stack