What’s Vulnerable › Vulnerabilities
CVE-2026-104939: NGINX Ingress Controller vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-15
- Weakness: CWE-303
Description
Description NGINX Ingress Controller has a vulnerability when implementing an externalAuth policy for ingress. NGINX Ingress Controller may mishandle the HTTP response from an OAuth IdP and allow an attacker to acquire unauthenticated access to protected paths before the proper external authentication can happen. Impact This vulnerability may allow remote attackers unauthenticated access to protected paths. There is no control plane exposure; this is a data plane issue only. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 NGINX Ingress Controller: from 5.6.0 before 5.7.0 — fixed in 5.7.0
How to fix
Upgrade to a fixed version: F5 NGINX Ingress Controller 5.7.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-104939 or the next vulnerability affects your stack