What’s Vulnerable › Vulnerabilities
CVE-2026-104947
- Severity: medium (CVSS 5.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-30
- Weakness: CWE-862
Description
WarehousePG (WHPG) 7.2.1 through 7.6.0 is affected by a missing authorization vulnerability (CWE-862) in the built-in function gp_log_backend_memory_contexts(). Any authenticated database role can run this function without a GRANT. It also gets around the superuser restriction that PostgreSQL places on the underlying pg_log_backend_memory_contexts() function. A low-privileged user can force the segment backends of any other session, superuser sessions included, to write their memory context details to the segment server logs, which the attacker cannot read. Those details can include query text from other users' cached plans, and the call can be repeated to generate large amounts of log output. WarehousePG 6.x is not affected.
Affected products
- EnterpriseDB WarehousePG: from 7.2.1 before 7.6.1 — fixed in 7.6.1
How to fix
Upgrade to a fixed version: EnterpriseDB WarehousePG 7.6.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-104947 or the next vulnerability affects your stack