What’s Vulnerable › Vulnerabilities
CVE-2026-104982: Linux Mint Xreader EPUB File epub-document.c g_strdup_printf path traversal
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-03 · updated 2026-10-06
- Weakness: CWE-22
Description
A flaw has been found in Linux Mint Xreader up to 4.6.5. This issue affects the function setup_document_content_list/g_strdup_printf of the file backend/epub/epub-document.c of the component EPUB File Handler. This manipulation causes path traversal. The attack is possible to be carried out remotely. The exploit has been published and may be used. Upgrading to version 4.6.6 is capable of addressing this issue. Patch name: a5aecea074e8564b7a22f1ce054b31ec862974b7. It is advisable to upgrade the affected component. One of the project maintainers explains, that "EPUB support was removed from Xreader and reimplemented in Xepub".
Affected products
- Linux Mint Xreader: 4.6.0, 4.6.1, 4.6.2, 4.6.3, 4.6.4, 4.6.5
References
- https://gist.github.com/rodtvs/63a34e7b20a9f97a1a7167a8a1db49c2
- https://github.com/linuxmint/xreader/commit/a5aecea074e8564b7a22f1ce054b31ec862974b7
- https://github.com/linuxmint/xreader/issues/713
- https://github.com/linuxmint/xreader/releases/tag/4.6.6
- https://vuldb.com/cve/CVE-2026-104982
- https://vuldb.com/submit/964347
- https://vuldb.com/vuln/413198
- https://vuldb.com/vuln/413198/cti
Get alerted when CVE-2026-104982 or the next vulnerability affects your stack