What’s Vulnerable › Vulnerabilities
CVE-2026-105107: Koha SQL injection in reports/cat_issues_top.pl via the Criteria, Filter and Limit request parameters
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-15
- Weakness: CWE-89
Description
Koha is vulnerable to SQL injection in the Most-circulated items report. The reports/cat_issues_top.pl script (sub calculate) concatenates the user-controlled Criteria, Filter, and Limit request parameters directly into dynamic SQL. Criteria is only prefix-normalized and never validated against an allow-list, so it is inserted verbatim into identifier positions (SELECT DISTINCTROW, GROUP BY, ORDER BY, and the main calculation query). Filter values are concatenated raw into single-quoted LIKE, BETWEEN, and comparison fragments. Limit is appended raw to a LIMIT clause. An authenticated staff user with the reports module permission (not requiring superlibrarian) can inject arbitrary SQL and read any table reachable by the Koha database user, including borrowers (userid and bcrypt password hashes, two-factor secrets, personal data), api_keys, and sessions. The issue is fixed in Koha 24.11.19, 25.05.14, 25.11.08, and 26.05.03, and in the 26.11 development branch. This is the unpatched twin of reports/bor_issues_top.pl (CVE-2026-70372).
Affected products
- Koha Community Koha: before 24.11.00; from 24.11.00 before 24.11.19; from 25.05.00 before 25.05.14; from 25.11.00 before 25.11.08; from 26.05.00 before 26.05.03 — fixed in 24.11.00, 24.11.19, 25.05.14, 25.11.08, 26.05.03
How to fix
Upgrade to a fixed version: Koha Community Koha 24.11.00, 24.11.19, 25.05.14, 25.11.08. Check the vendor advisory for mitigations.
References
- https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=42736
- https://download.koha-community.org/
- https://www.cve.org/CVERecord?id=CVE-2026-6428
- https://www.cve.org/CVERecord?id=CVE-2026-70372
Get alerted when CVE-2026-105107 or the next vulnerability affects your stack