What’s Vulnerable › Vulnerabilities
CVE-2026-105122: OpenAM before 16.1.3 SSRF via OpenID Connect Client jwks_uri
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-03 · updated 2026-10-06
- Weakness: CWE-918
Description
OpenAM before 16.1.3 contains a server-side request forgery vulnerability that allows attackers able to register or modify OAuth 2.0 clients to make OpenAM fetch internal resources via an unvalidated jwks_uri. Attackers can trigger unauthenticated fetches through client-authentication and ID-token validation to probe internal hosts, metadata endpoints or local files, or exhaust request threads for denial of service.
Affected products
- OpenIdentityPlatform OpenAM: before 16.1.3 — fixed in 16.1.3
How to fix
Upgrade to a fixed version: OpenIdentityPlatform OpenAM 16.1.3. Check the vendor advisory for mitigations.
References
- https://github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-g7cv-hh35-cc7c
- https://www.vulncheck.com/advisories/openam-before-16.1.3-ssrf-via-openid-connect-client-jwks-uri
Get alerted when CVE-2026-105122 or the next vulnerability affects your stack