What’s Vulnerable › Vulnerabilities
CVE-2026-105125: LaraDashboard before 1.4.8 Path Traversal via /api/translations/{lang} Endpoint
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-04 · updated 2026-10-05
- Weakness: CWE-22
Description
LaraDashboard before 1.4.8 contains a path traversal vulnerability that allows unauthenticated attackers to read JSON files by manipulating the {lang} route segment. On Windows hosts, attackers can send URL-encoded backslash sequences like ..%5C to escape resources/lang and read composer.json or other application JSON files.
Affected products
- laradashboard: before 1.4.8 — fixed in 1.4.8
How to fix
Upgrade to a fixed version: laradashboard 1.4.8. Check the vendor advisory for mitigations.
References
- https://github.com/laradashboard/laradashboard
- https://github.com/laradashboard/laradashboard/blob/v1.4.2/routes/api.php#L36-L46
- https://github.com/laradashboard/laradashboard/commit/aa5d33a32ccef07618ae8687247540d73a21505e
- https://github.com/laradashboard/laradashboard/pull/350
- https://github.com/laradashboard/laradashboard/releases/tag/v1.4.8
- https://github.com/laradashboard/laradashboard/security/advisories/GHSA-43jp-66c9-7cgh
- https://www.vulncheck.com/advisories/laradashboard-before-1.4.8-path-traversal-via-api-translations-lang-endpoint
Get alerted when CVE-2026-105125 or the next vulnerability affects your stack