What’s Vulnerable › Vulnerabilities
CVE-2026-105131: mayswind ezBookkeeping 1.2.0 before 2.0.1 Privilege Escalation via Token Refresh Endpoint
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-04 · updated 2026-10-06
- Weakness: CWE-863
Description
ezBookkeeping 1.2.0 before 2.0.1 contains a privilege escalation vulnerability that allows attackers holding an API token to obtain a full session token via /api/v1/tokens/refresh.json. Because TokenRefreshHandler never checks token type, attackers can exchange short-lived or IP-restricted API tokens for 30-day normal session tokens that bypass API token expiry and allowlists.
Affected products
- mayswind ezBookkeeping: from 1.2.0 before 2.0.1 — fixed in 2.0.1
How to fix
Upgrade to a fixed version: mayswind ezBookkeeping 2.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/mayswind/ezbookkeeping
- https://github.com/mayswind/ezbookkeeping/blob/v2.0.0/pkg/api/tokens.go#L327-L380
- https://github.com/mayswind/ezbookkeeping/commit/9a92b07be8a7034665abfdb35b036210a1d57bf9
- https://github.com/mayswind/ezbookkeeping/releases/tag/v2.0.1
- https://github.com/mayswind/ezbookkeeping/security/advisories/GHSA-wq25-mpcf-2mfc
- https://www.vulncheck.com/advisories/mayswind-ezbookkeeping-1.2.0-before-2.0.1-privilege-escalation-via-token-refresh-endpoint
Get alerted when CVE-2026-105131 or the next vulnerability affects your stack