What’s Vulnerable › Vulnerabilities

CVE-2026-105133: Ahsay AhsayCBS Improper Authentication Vulnerability

Description

A vulnerability was detected in Ahsay AhsayCBS up to 9.15.2.69/10.3.4.44. This affects the function checkSysPwd of the file com/ahsay/obs/api/ApiStructsAction.java of the component API. Performing a manipulation of the argument random results in improper authentication. It is possible to initiate the attack remotely. The exploit is now public and may be used. Upgrading to version 9.15.2.70 and 10.3.4.45 is able to mitigate this issue. It is recommended to upgrade the affected component. The initial patch did not fix the security vulnerability properly. An update of the CVE entry to reflect this became necessary.

Affected products

How to fix

Upgrade to a fixed version: Ahsay Cloud Backup Suite 9.15.2.70, 10.3.4.45. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-105133 or the next vulnerability affects your stack