What’s Vulnerable › Vulnerabilities

CVE-2026-105134: Ahsay AhsayCBS Command Injection Vulnerability

Description

A flaw has been found in Ahsay AhsayCBS up to 9.15.2.69/10.3.4.44. This vulnerability affects unknown code of the file /rps/api/json/UpdateReceivers.do of the component Replication Receiver. Executing a manipulation of the argument random can lead to os command injection. It is possible to launch the attack remotely. The exploit has been published and may be used. Upgrading to version 9.15.2.70 and 10.3.4.45 is able to resolve this issue. Upgrading the affected component is advised. The initial patch did not fix the security vulnerability properly. An update of the CVE entry to reflect this became necessary.

Affected products

How to fix

Upgrade to a fixed version: Ahsay Cloud Backup Suite 9.15.2.70, 10.3.4.45. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-105134 or the next vulnerability affects your stack