What’s Vulnerable › Vulnerabilities

CVE-2026-10518: Incorrect Authorization in GitLab

Description

GitLab has remediated an issue in GitLab EE affecting all versions from 17.9 before 19.2.7, 19.3 before 19.3.3, and 19.4 before 19.4.1 that under certain conditions could have allowed an authenticated user with guest-level permissions to read private security policy content they were not authorized to access due to improper authorization enforcement.

Affected products

How to fix

Upgrade to a fixed version: GitLab 19.2.7, 19.3.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-10518 or the next vulnerability affects your stack