What’s Vulnerable › Vulnerabilities
CVE-2026-105219: Mammoth.js 1.3.0 before 1.12.3 ReDoS via Style Map Tokeniser
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-04 · updated 2026-10-06
- Weakness: CWE-1333
Description
Mammoth.js 1.3.0 before 1.12.3 contains a regular expression denial of service vulnerability in the style map tokeniser in lib/styles/parser/tokeniser.js due to overlapping regex alternatives. Attackers can supply a crafted .docx with an unterminated quoted string of repeated backslash escapes in mammoth/style-map to block the Node.js event loop.
Affected products
- mwilliamson mammoth.js: from 1.3.0 before 1.12.3 — fixed in 1.12.3
How to fix
Upgrade to a fixed version: mwilliamson mammoth.js 1.12.3. Check the vendor advisory for mitigations.
References
- https://github.com/mwilliamson/mammoth.js
- https://github.com/mwilliamson/mammoth.js/blob/1.12.2/lib/styles/parser/tokeniser.js#L6-L30
- https://github.com/mwilliamson/mammoth.js/commit/dc49225425c2c07de0a6dc3529f2386c82a032b4
- https://github.com/mwilliamson/mammoth.js/issues/487
- https://www.vulncheck.com/advisories/mammoth-js-1.3.0-before-1.12.3-redos-via-style-map-tokeniser
Get alerted when CVE-2026-105219 or the next vulnerability affects your stack