What’s Vulnerable › Vulnerabilities
CVE-2026-105221: Gist RubyGem before 6.1.0 Disabled TLS Certificate Verification
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-04 · updated 2026-10-06
- Weakness: CWE-295
Description
The gist RubyGem before 6.1.0 contains an improper certificate validation vulnerability that allows on-path attackers to intercept HTTPS traffic because http_connection in lib/gist.rb sets VERIFY_NONE. Attackers can present any certificate to read or modify GitHub API traffic, stealing OAuth tokens and login credentials to read and modify the victim's gists.
Affected products
- defunkt gist: from 4.0.0 before 6.1.0 — fixed in 6.1.0
How to fix
Upgrade to a fixed version: defunkt gist 6.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/defunkt/gist
- https://github.com/defunkt/gist/blob/v6.0.0/lib/gist.rb#L466-L468
- https://github.com/defunkt/gist/commit/07ccc1a6d46e9d36f0e85d0b1c5d795890ae6bcf
- https://github.com/defunkt/gist/issues/373
- https://www.vulncheck.com/advisories/gist-rubygem-before-6.1.0-disabled-tls-certificate-verification
Get alerted when CVE-2026-105221 or the next vulnerability affects your stack