What’s Vulnerable › Vulnerabilities
CVE-2026-10524: CoCart < 4.9.0 - Unauthenticated Arbitrary Price Manipulation
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-06 · updated 2026-08-26
- Weakness: CWE-472
Description
The CoCart WordPress plugin before 4.9.0 does not validate a user-supplied price value against the actual product price when items are added to the cart through one of its public REST API endpoints, allowing unauthenticated users to set arbitrary product prices and complete WooCommerce orders at manipulated totals.
Affected products
- CoCart: before 4.9.0 — fixed in 4.9.0
How to fix
Upgrade to a fixed version: CoCart 4.9.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-10524 or the next vulnerability affects your stack