What’s Vulnerable › Vulnerabilities
CVE-2026-105261: PublishPress Future 4.10.1 - 4.10.5 - Contributor+ Stored XSS via 'wrapper' and 'dateformat' Shortcode Attributes
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-14
- Weakness: CWE-79
Description
The Schedule Post Changes With PublishPress Future: Unpublish, Delete, Change Status, Trash, Change Categories WordPress plugin before 4.10.6 does not enforce a safe HTML-element allowlist on a shortcode attribute and does not neutralise attacker-controlled text placed inside the resulting element, allowing users with the Contributor role and above to store JavaScript that executes in the session of any higher-privileged user who views the content.
Affected products
- Schedule Post Changes With PublishPress Future: Unpublish, Delete, Change Status, Trash, Change Categories: from 4.10.1 before 4.10.6 — fixed in 4.10.6
How to fix
Upgrade to a fixed version: Schedule Post Changes With PublishPress Future: Unpublish, Delete, Change Status, Trash, Change Categories 4.10.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-105261 or the next vulnerability affects your stack