What’s Vulnerable › Vulnerabilities
CVE-2026-10527: Boards plugin retains Board Admin rights for users demoted to System Guest
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-17 · updated 2026-08-18
- Weakness: CWE-863
Description
Mattermost versions 11.7.x <= 11.7.6, 10.11.x <= 10.11.21, 11.8.x <= 11.8.3 fails to reconcile SchemeAdmin flags with a user's current role which allows a user demoted to System Guest to retain Board Admin privileges and perform admin-only operations via the Boards REST API or UI.. Mattermost Advisory ID: MMSA-2026-00691
Affected products
- Mattermost: from 10.11.0 before 10.11.22; from 11.7.0 before 11.7.7; from 11.8.0 before 11.8.4 — fixed in 10.11.22, 11.7.7, 11.8.4
How to fix
Upgrade to a fixed version: Mattermost 10.11.22, 11.7.7, 11.8.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-10527 or the next vulnerability affects your stack