What’s Vulnerable › Vulnerabilities
CVE-2026-10535: IBM® Db2® is vulnerable to buffer overflow in setgid helper db2flacc which can lead to privilege escalation and instance compromise from an unprivileged shell
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-30 · updated 2026-10-23
- Weakness: CWE-121
Description
IBM Db2 11.5.0 through 11.5.9, and 12.1.0 through 12.1.4 is vulnerable to buffer overflow in setgid helper db2flacc.
Affected products
- IBM Db2 for Linux, UNIX and Windows: from 11.5.0 through 11.5.9; from 12.1.0 before 12.1.5 — fixed in 12.1.5
How to fix
Upgrade to a fixed version: IBM Db2 for Linux, UNIX and Windows 12.1.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-10535 or the next vulnerability affects your stack