What’s Vulnerable › Vulnerabilities

CVE-2026-105458: Reliance on Untrusted Inputs in a Security Decision in GitLab

Description

GitLab has remediated an issue in GitLab EE affecting all versions from 19.1 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an authenticated user holding a specific granular permission to obtain a GitLab Duo Agent Platform token that bypasses governance controls, due to reliance on untrusted input in a security decision.

Affected products

How to fix

Upgrade to a fixed version: GitLab 19.2.8, 19.3.5, 19.4.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-105458 or the next vulnerability affects your stack