What’s Vulnerable › Vulnerabilities
CVE-2026-10551: Breeze Cache < 2.5.6 - Unauthenticated Stored XSS via Minify Library
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-13 · updated 2026-07-13
Description
The Breeze Cache WordPress plugin before 2.5.6 is vulnerable to unauthenticated Stored Cross-Site Scripting (XSS) due to a predictable replacement hash used during the HTML minification process and abusing a regular expression. This allows an attacker to inject arbitrary HTML attributes in the final HTML output by anticipating the placeholder format.
Affected products
- Breeze Cache: before 2.5.6 — fixed in 2.5.6
How to fix
Upgrade to a fixed version: Breeze Cache 2.5.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-10551 or the next vulnerability affects your stack