What’s Vulnerable › Vulnerabilities
CVE-2026-105626: Consul vulnerable to a denial of service in HTTP APIs
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-26 · updated 2026-10-26
- Weakness: CWE-770
Description
HashiCorp Consul and Consul Enterprise are vulnerable to a denial of service in the HTTP API that may allow an unauthenticated attacker to exhaust memory on a Consul agent. This vulnerability (CVE-2026-105626) is fixed in Consul Community Edition 2.1.0 and Consul Enterprise 2.1.0 and 1.21.19.
Affected products
- HashiCorp Consul: from 0.6.0 before 2.1.0 — fixed in 2.1.0
- HashiCorp Consul Enterprise: from 0.6.0 before 2.1.0 — fixed in 2.1.0
How to fix
Upgrade to a fixed version: HashiCorp Consul 2.1.0; HashiCorp Consul Enterprise 2.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-105626 or the next vulnerability affects your stack