What’s Vulnerable › Vulnerabilities

CVE-2026-10569: IBM DevOps Deploy / IBM UrbanCode Deploy (UCD) is susceptible to an Exposure of Sensitive Information Vulnerability

Description

IBM UCD - IBM UrbanCode Deploy 7.2 through 7.2.3.23, and 7.3 through 7.3.2.18 and IBM UCD - IBM DevOps Deploy 8.0 through 8.0.1.13, 8.1 through 8.1.2.6, and 8.2 through 8.2.1.0 is susceptible to an Exposure of Sensitive Information Vulnerability in plugin output logs. This exposure could allow an attacker with access to the logs to potentially obtain senstive values related to that step.

Affected products

How to fix

Upgrade to a fixed version: IBM DevOps Deploy 8.0.1.14, 8.1.2.7, 8.2.2.0; IBM UrbanCode Deploy 7.2.3.24, 7.3.2.19. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-10569 or the next vulnerability affects your stack