What’s Vulnerable › Vulnerabilities
CVE-2026-105758: vLLM: Qwen2-VL / Qwen3-VL video samplers bound on request-controlled max_frames, which the num_frames ceiling does not reach
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-05 · updated 2026-10-08
- Weakness: CWE-770
Description
vLLM is an inference and serving engine for large language models. From 0.24.0 until 0.30.0, the Qwen2VLVideoBackend and Qwen3VLVideoBackend classes accept request-level values for the media_io_kwargs.video.max_frames and media_io_kwargs.video.fps fields without enforcing server-side ceilings. An unauthenticated caller can submit these values to the /tokenize endpoint, causing the sampler to decode every frame selected from attacker-controlled video input, consume disproportionate frontend memory, and potentially terminate the API process before scheduling or admission control. The Rust frontend is not affected because it rejects the media_io_kwargs field. This issue is fixed in version 0.30.0.
Affected products
- vllm-project vllm: from 0.24.0 before 0.30.0 — fixed in 0.30.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.30.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/commit/ea723c81c3ea26425cb69503a5d5e90822a04a45
- https://github.com/vllm-project/vllm/pull/56729
- https://github.com/vllm-project/vllm/releases/tag/v0.30.0
- https://github.com/vllm-project/vllm/security/advisories/GHSA-x6mc-67gf-chw4
Get alerted when CVE-2026-105758 or the next vulnerability affects your stack