What’s Vulnerable › Vulnerabilities
CVE-2026-105768: apko /etc/passwd and /etc/group UID/GID truncation writes package-supplied entries as root
- Severity: medium (CVSS 6.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-05 · updated 2026-10-06
- Weakness: CWE-197
Description
apko allows users to build and publish OCI container images built from apk packages. From version 0.2.0 to before version 1.4.5, UserEntry.Parse and GroupEntry.Parse in pkg/passwd read the UID and GID fields of /etc/passwd and /etc/group entries with strconv.Atoi and convert them to uint32 without a range check. On 64-bit platforms an out-of-range value such as 4294967296 (2^32) is truncated to 0, and negative values wrap. Because apko parses the passwd and group entries supplied by the packages it installs and writes them back into the image, an attacker who controls a package installed into the image can ship an entry that appears to declare an unprivileged UID or GID but is written into the built image as UID 0 or GID 0 (root). The truncated UID is also used when resolving the image's run-as user. This issue has been fixed in version 1.4.5.
Affected products
- chainguard-dev apko: from 0.2.0 before 1.4.5 — fixed in 1.4.5
How to fix
Upgrade to a fixed version: chainguard-dev apko 1.4.5. Check the vendor advisory for mitigations.
References
- https://github.com/chainguard-dev/apko/commit/739e7ce3f675ffb232e16849b51ff93657f1570c
- https://github.com/chainguard-dev/apko/pull/2516
- https://github.com/chainguard-dev/apko/releases/tag/v1.4.5
- https://github.com/chainguard-dev/apko/security/advisories/GHSA-rj6x-hwpv-vhvf
Get alerted when CVE-2026-105768 or the next vulnerability affects your stack