What’s Vulnerable › Vulnerabilities

CVE-2026-105777: Insertion of Sensitive Information Into Sent Data in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 17.6.5 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that, under certain conditions, an unauthenticated user could have retrieved sensitive internal server credentials due to improper filtering of internal response headers.

Affected products

How to fix

Upgrade to a fixed version: GitLab 19.3.6, 19.4.3; GitLab 19.3.6, 19.4.3, 19.5.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-105777 or the next vulnerability affects your stack