What’s Vulnerable › Vulnerabilities
CVE-2026-105818: Vault PKI ACME Issues Certificate With Unvalidated SANs
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-07 · updated 2026-10-08
- Weakness: CWE-345
Description
Vault's PKI secrets engine ACME server did not restrict certificate identities that ACME challenges do not validate when issuing certificates under the default directory policy. This may allow an ACME client to obtain a certificate containing unverified identity claims, potentially enabling impersonation toward systems that trust certificates issued by the affected Vault PKI mount. This vulnerability (CVE-2026-105818) is fixed in Vault Community Edition 2.1.2, and Vault Enterprise 2.1.2, 1.21.12, 1.20.17, and 1.19.23.
Affected products
- HashiCorp Vault: from 1.14.0 before 2.1.2 — fixed in 2.1.2
How to fix
Upgrade to a fixed version: HashiCorp Vault 2.1.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-105818 or the next vulnerability affects your stack