What’s Vulnerable › Vulnerabilities

CVE-2026-105828: Parse Server 9.0.0 before 9.10.1-alpha.12 Class Name Disclosure via GraphQL Errors

Description

Parse Server 8.2.2 before 8.6.92 and 9.0.0 before 9.10.1-alpha.12 contains an information disclosure vulnerability in which GraphQL validation error messages reveal hidden class names when public introspection is disabled. Unauthenticated attackers holding only the public Application Id can send crafted operations triggering unknown-argument or invalid enum value errors to learn pointer and relation target classes.

Affected products

How to fix

Upgrade to a fixed version: parse-community parse-server 8.6.92, 9.10.1-alpha.12. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-105828 or the next vulnerability affects your stack