What’s Vulnerable › Vulnerabilities
CVE-2026-105837: libmikmod before 3.3.14 Heap Buffer Overflow via DSM Loader Integer Overflow
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-06 · updated 2026-10-06
- Weakness: CWE-190
Description
libmikmod before 3.3.14 contains an integer overflow vulnerability in DSM_Load() in load_dsm.c that allows attackers to trigger heap buffer overflow via crafted track counts. Attackers can supply a DSM module whose numchn and numpat product wraps a 16-bit value, overwriting heap memory to cause crashes or potential code execution.
Affected products
- sezero libmikmod: before 3.3.14 — fixed in 3.3.14
How to fix
Upgrade to a fixed version: sezero libmikmod 3.3.14. Check the vendor advisory for mitigations.
References
- https://github.com/sezero/mikmod
- https://github.com/sezero/mikmod/blob/libmikmod-3.3.13/libmikmod/loaders/load_dsm.c#L273
- https://github.com/sezero/mikmod/blob/libmikmod-3.3.14/libmikmod/NEWS
- https://github.com/sezero/mikmod/commit/a125eabbd086f311496ae46d08aaebcad0a1c426
- https://www.vulncheck.com/advisories/libmikmod-before-3.3.14-heap-buffer-overflow-via-dsm-loader-integer-overflow
Get alerted when CVE-2026-105837 or the next vulnerability affects your stack