What’s Vulnerable › Vulnerabilities
CVE-2026-105839: libmikmod before 3.3.14 Heap Buffer Overflow via OKT Loader OKT_doPBOD
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-06 · updated 2026-10-06
- Weakness: CWE-190
Description
libmikmod before 3.3.14 contains an integer overflow in the Oktalyzer loader OKT_doPBOD() that allows attackers to cause heap buffer overflow via crafted track counts. Attackers can supply an OKT module whose SLEN chunk wraps the 16-bit numtrk value, causing PBOD writes past allocated track pointers for crashes or code execution.
Affected products
- sezero libmikmod: before 3.3.14 — fixed in 3.3.14
How to fix
Upgrade to a fixed version: sezero libmikmod 3.3.14. Check the vendor advisory for mitigations.
References
- https://github.com/sezero/mikmod
- https://github.com/sezero/mikmod/blob/libmikmod-3.3.13/libmikmod/loaders/load_okt.c#L286
- https://github.com/sezero/mikmod/blob/libmikmod-3.3.14/libmikmod/NEWS
- https://github.com/sezero/mikmod/commit/097b69281fad6ba38a553569e6f55dbfdd71dc2a
- https://www.vulncheck.com/advisories/libmikmod-before-3.3.14-heap-buffer-overflow-via-okt-loader-okt-dopbod
Get alerted when CVE-2026-105839 or the next vulnerability affects your stack