What’s Vulnerable › Vulnerabilities
CVE-2026-105850: Payload: Order confirmation validation issue in Payload Ecommerce
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-06 · updated 2026-10-15
- Weakness: CWE-837
Description
Payload is a free and open source headless content management system. In @payloadcms/plugin-ecommerce versions before 3.90.0 and canary versions before 4.0.0-canary.34, use of the Stripe payment adapter can allow a Stripe order confirmation to be processed more than once under certain conditions. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.
Affected products
- payloadcms payload: before 3.90.0; 4.0.0-canary0, 4.0.0-canary1, 4.0.0-canary10, 4.0.0-canary11, 4.0.0-canary12, 4.0.0-canary13 (+28) — fixed in 3.90.0
How to fix
Upgrade to a fixed version: payloadcms payload 3.90.0. Check the vendor advisory for mitigations.
References
- https://github.com/payloadcms/payload/commit/6c0c4dc9b4ce1ac87b03fbb5dd7356b8559cbc4e
- https://github.com/payloadcms/payload/releases/tag/v3.90.0
- https://github.com/payloadcms/payload/security/advisories/GHSA-8r29-2mp2-pmrw
Get alerted when CVE-2026-105850 or the next vulnerability affects your stack