What’s Vulnerable › Vulnerabilities
CVE-2026-105855: Payload: Field-level password update restrictions were not enforced
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-06 · updated 2026-10-15
- Weakness: CWE-284
Description
Payload is a free and open source headless content management system. In versions before 3.90.0 and canary versions before 4.0.0-canary.34, the server fails to enforce a field-level access.update restriction on the password field of an authentication collection. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.
Affected products
- payloadcms payload: before 3.90.0; 4.0.0-canary0, 4.0.0-canary1, 4.0.0-canary10, 4.0.0-canary11, 4.0.0-canary12, 4.0.0-canary13 (+28) — fixed in 3.90.0
How to fix
Upgrade to a fixed version: payloadcms payload 3.90.0. Check the vendor advisory for mitigations.
References
- https://github.com/payloadcms/payload/commit/9de9e7911e29d60870a1d5480412524c63d6411e
- https://github.com/payloadcms/payload/releases/tag/v3.90.0
- https://github.com/payloadcms/payload/security/advisories/GHSA-fx49-4h83-wjv9
Get alerted when CVE-2026-105855 or the next vulnerability affects your stack