What’s Vulnerable › Vulnerabilities
CVE-2026-105857: Payload: RCE in Payload Form Builder
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-06 · updated 2026-10-15
- Weakness: CWE-94
Description
Payload is a free and open source headless content management system. In @payloadcms/plugin-form-builder versions before 3.90.0 and canary versions before 4.0.0-canary.34, an attacker can craft a form submission that executes code remotely on the server. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.
Affected products
- payloadcms payload: before 3.90.0; 4.0.0-canary0, 4.0.0-canary1, 4.0.0-canary10, 4.0.0-canary11, 4.0.0-canary12, 4.0.0-canary13 (+28) — fixed in 3.90.0
How to fix
Upgrade to a fixed version: payloadcms payload 3.90.0. Check the vendor advisory for mitigations.
References
- https://github.com/payloadcms/payload/commit/333b82b9f3e685fed6826c2e3270da79df8336c6
- https://github.com/payloadcms/payload/releases/tag/v3.90.0
- https://github.com/payloadcms/payload/security/advisories/GHSA-r488-j9vj-wx3q
Get alerted when CVE-2026-105857 or the next vulnerability affects your stack