What’s Vulnerable › Vulnerabilities
CVE-2026-105996: Booking Package < 1.7.31 - Unauthenticated Booking PII Disclosure and Cancellation via Predictable Token
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-21
- Weakness: CWE-326
Description
The Booking Package WordPress plugin before 1.7.31 does not generate booking cancellation tokens using a secure source of randomness, deriving them instead from values it exposes publicly, so an unauthenticated attacker can reconstruct an arbitrary booking's token, disclose that booking's personal data and, where visitor cancellation is enabled, cancel the booking.
Affected products
- Booking Package: before 1.7.31 — fixed in 1.7.31
How to fix
Upgrade to a fixed version: Booking Package 1.7.31. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-105996 or the next vulnerability affects your stack