What’s Vulnerable › Vulnerabilities
CVE-2026-106095: Code Snippets < 3.10.0 - Admin+ Network-Scoped Snippet Activation and Deactivation via update_code_snippet
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-09 · updated 2026-10-09
- Weakness: CWE-862
Description
The Code Snippets WordPress plugin before 3.10.0 does not perform a capability check on one of its snippet-management actions and derives the network scope of the targeted snippet from the request instead of from the stored record, allowing an administrator of a single subsite on a multisite network to activate, deactivate and reprioritise network-scoped snippets that run across every site in the network.
Affected products
- Code Snippets: before 3.10.0 — fixed in 3.10.0
How to fix
Upgrade to a fixed version: Code Snippets 3.10.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-106095 or the next vulnerability affects your stack