What’s Vulnerable › Vulnerabilities
CVE-2026-106100: Payload: Field-level write access bypass in Payload on MongoDB
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-06 · updated 2026-10-15
- Weakness: CWE-639
Description
Payload is a free and open source headless content management system. In @payloadcms/db-mongodb versions before 3.87.0 and canary versions before 4.0.0-canary.20, an authenticated user who can update a document can modify fields that field-level write access control does not permit that user to change. The Postgres and SQLite adapters are not affected. This issue is fixed in versions 3.87.0 and 4.0.0-canary.20.
Affected products
- payloadcms payload: before 3.87.0; 4.0.0-canary0, 4.0.0-canary1, 4.0.0-canary10, 4.0.0-canary11, 4.0.0-canary12, 4.0.0-canary13 (+14) — fixed in 3.87.0
How to fix
Upgrade to a fixed version: payloadcms payload 3.87.0. Check the vendor advisory for mitigations.
References
- https://github.com/payloadcms/payload/commit/2a69863deb0e3c87e36c1b3b17ab2d5b02fcb941
- https://github.com/payloadcms/payload/commit/8f77dffa9552885ec2710768cfee15b57e389935
- https://github.com/payloadcms/payload/releases/tag/v3.87.0
- https://github.com/payloadcms/payload/security/advisories/GHSA-4ww4-68q3-h7g5
Get alerted when CVE-2026-106100 or the next vulnerability affects your stack