What’s Vulnerable › Vulnerabilities
CVE-2026-106106: Quasar Framework: SSR/SSG dev error page discloses the full shell environment and its </script> escape is bypassable
- Severity: high (CVSS 7.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-06 · updated 2026-10-06
- Weakness: CWE-79
Description
Quasar Framework is a framework for building high-performance Vue.js user interfaces. Prior to @quasar/render-ssr-error 2.2.4 and @quasar/app-vite 3.3.0, renderSSRError() in utils/render-ssr-error/src/index.js used diagnostic data from utils/render-ssr-error/src/env.js to serialize process.env, request headers, and cookies into the HTTP page returned by serve.devError(), while the development server listened on all interfaces by default. Any network-adjacent client that reaches an SSR or SSG render failure through this development-only error path can obtain shell environment secrets. The renderer escaped only one exact lowercase script closing-tag spelling, so case variants and valid closing-tag delimiter variants in reflected diagnostic data could terminate the script element and inject markup; executing the injected code in a developer browser additionally requires the payload to accompany that developer's request. This issue is fixed in @quasar/render-ssr-error 2.2.4 and @quasar/app-vite 3.3.0.
Affected products
- @quasar app-vite: before 3.3.0
- @quasar render-ssr-error: before 2.2.4
- quasarframework quasar: before 2.23.3
References
- https://github.com/quasarframework/quasar/commit/61c2bd8a607785fdade72cce20e8faf1de7eee15
- https://github.com/quasarframework/quasar/releases/tag/@quasar/app-vite-v3.3.0
- https://github.com/quasarframework/quasar/security/advisories/GHSA-r5mf-4r5x-q78f
- https://github.com/quasarframework/quasar/security/advisories/GHSA-r5mf-4r5x-q78f
Get alerted when CVE-2026-106106 or the next vulnerability affects your stack