What’s Vulnerable › Vulnerabilities
CVE-2026-106122: RabbitMQ: Malformed UTF-8 in shortstr properties permanently disables RPC consumers
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-10-06 · updated 2026-10-09
- Weakness: CWE-172
Description
The RabbitMQ Java client library allows Java and JVM-based applications to connect to and interact with RabbitMQ nodes. Prior to 5.36.0, ValueReader.readShortstr decodes malformed UTF-8 bytes into replacement characters that can re-encode beyond the AMQP shortstr limit enforced by ValueWriter.writeShortstr. An attacker who can submit an RPC message with a malformed echoed property can cause reply publication in RpcServer.mainloop() or tutorial-style consumers to throw an unchecked exception before acknowledgement. The broker requeues the message, allowing the same message to disable replacement consumers until the queue is purged. This issue is fixed in version 5.36.0.
Affected products
- rabbitmq-java-client: before 5.36.0 — fixed in 5.36.0
- com.rabbitmq amqp-client: before 5.36.0
- rabbitmq-java-client: before 5.36.0
How to fix
Upgrade to a fixed version: rabbitmq-java-client 5.36.0. Check the vendor advisory for mitigations.
References
- https://github.com/rabbitmq/rabbitmq-java-client/commit/b8bd750fa8c90690e859b18d6343b34421309020
- https://github.com/rabbitmq/rabbitmq-java-client/pull/2065
- https://github.com/rabbitmq/rabbitmq-java-client/releases/tag/v5.36.0
- https://github.com/rabbitmq/rabbitmq-java-client/security/advisories/GHSA-7822-rcf6-97fx
- https://github.com/rabbitmq/rabbitmq-java-client/security/advisories/GHSA-7822-rcf6-97fx
Get alerted when CVE-2026-106122 or the next vulnerability affects your stack