What’s Vulnerable › Vulnerabilities
CVE-2026-106150: Cross-site Scripting (XSS) in Kendo UI for jQuery Splitter, Window, and Tooltip
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-15 · updated 2026-10-15
- Weakness: CWE-79
Description
In Progress® Kendo® UI for jQuery prior to 2026.3.1015, the Splitter and Window components starting with version 2011.2.804 and the Tooltip component starting with version 2013.1.319 construct iframe markup without properly sanitizing URL values or encoding the Window iframe title. An attacker with low privileges who can control these values can inject HTML attributes, including JavaScript event handlers, through an apostrophe in an iframe URL or a crafted title. When a user interacts with the affected component, injected JavaScript can execute in the user's browser context, compromising the confidentiality and integrity of accessible data.
Affected products
- Progress Software Kendo UI for jQuery: from 2013.1.319 before 2026.3.1015; from 2011.2.804 before 2026.3.1015 — fixed in 2026.3.1015
How to fix
Upgrade to a fixed version: Progress Software Kendo UI for jQuery 2026.3.1015. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-106150 or the next vulnerability affects your stack