What’s Vulnerable › Vulnerabilities
CVE-2026-106151: Cross-Site Scripting in Validator Validation Messages in Kendo UI for jQuery
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-15 · updated 2026-10-20
- Weakness: CWE-80
Description
In Progress® Kendo® UI for jQuery versions starting with 2012.2.710 and prior to 2026.3.1015, the Validator decodes validation messages from data-msg-* attributes and parses the resulting text as HTML. An attacker who can modify a validation message can cause HTML that was correctly escaped in the page attribute to become active markup, including event handlers, when the user triggers validation. Successful exploitation can execute JavaScript in a user's browser and compromise the confidentiality and integrity of data accessible to the affected application. This issue is fixed in version 2026.3.1015.
Affected products
- Progress Software Kendo UI for jQuery: from 2012.2.710 before 2026.3.1015 — fixed in 2026.3.1015
How to fix
Upgrade to a fixed version: Progress Software Kendo UI for jQuery 2026.3.1015. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-106151 or the next vulnerability affects your stack